login vsi company logo login vsi company logo 250x40

Remote Desktop Connections start but no activity

  • ajit
  • ajit's Avatar Topic Author
27 Aug 2012 22:37 #483


I am using Login VSI to test performance of Remote Desktop Sessions.
I have ec2 m1.large instances of Windows Server 2008 R2 as my target as well as launcher.
I have followed the steps in the installation guide and everything seems to be fine. Except that when I start the test, the Remote Desktop connection is opened and just idle. Could you give some advice as to where I can look for debug information or log file so that I can check what is going wrong?

Please Log in to join the conversation.

  • ajit
  • ajit's Avatar Topic Author
27 Aug 2012 22:42 #484

I saw the other similar post by John Renko. I also confirmed that the share folder is accessible via the RD Connections as well as the Target setup has been run on the Target host.

Please Log in to join the conversation.

28 Aug 2012 03:39 #485

This means that the VSI logon script isn't being started. This can have several causes.

Can you please check/answer the following for me:
1. You are using users generated by the Login VSI Active Directory setup.
2. The users generated have a logon attribute that points to VSI_logon.cmd, see Logon_Script_Attribute.jpg.
3. A VSI_Logon.cmd file exists in \\YOURDOMAIN\sysvol\YOURDOMAIN\Scripts\
4. What happens when one of the Login_VSI users logs on to your target environment? For reference, we call the environment that you want to benchmark the target environment.

Please Log in to join the conversation.

  • ajit
  • ajit's Avatar Topic Author
28 Aug 2012 14:41 #486

Hi Dennis,

I confirmed all the 3 things in your list.
For the 4th point - When I use a Login_VSI user to log on to the target environment - nothing special happens. It's exactly as if some other user has logged in.

One thing I am slightly doubtful about - is the Login_VSI OU in the Active Directory and the VSI_System policy. As per the Admin guide - the target computer has been moved to the Login_VSI/Computers OU and th VSI_System policy has been linked to that OU. I have also tried to set it as "enforced" and otherwise.

When the Login_VSI users are generated by the AD setup, should I expect them to automatically have remote-desktop privileges? I had to manually add the domain group Login_VSI_TS to the "Remote Desktop Users" local group on the Target machine to allow Login_VSI users to be able to start remote desktop connections. Is this the right way or does that signal something wrong with my setup?


Please Log in to join the conversation.

29 Aug 2012 03:59 #488

The OU isn't likely the issue. Pretty much every setting in the OU is optional but geared towards making your life easier.

The VSI target setup makes the Login_VSI_TS group a member of the "Remote Desktop Users" group. There is no group to add ff the target setup runs before the AD setup has been executed though.

Regarding your issue:
Once you are logged on as one of the Login_VSI users, are you able to browse to the \\YOURDOMAIN\sysvol\YOURDOMAIN\scripts folder and execute VSI_Logon.cmd?
Executing this script should happen without any security prompts. A security prompt indicates that the client thinks the sysvol share is located on the internet. In that case, Windows will not allow the script to be executed automatically.

Please Log in to join the conversation.

  • ajit
  • ajit's Avatar Topic Author
29 Aug 2012 14:23 #491

Thanks Dennis, I explored a few options in the GPMC related to logon scripts and was able to make it run.
I posted the solution earlier but somehow the post did not show up in the replies.

I followed instructions in this link to ensure that the scripts get run even when the network bandwidth is low:

I also had to modify the VSI_User Group Policy Object in the Group Policy Management Console. I explicitly configured the VSI_Logon script to run on logon for the VSI_Login/Users/Target group.
This can be done as follows:
1) Open the Group Policy Management Console.
2) Expand the tree structure on the left to browse to the Login_VSI/Users/Target OU. Notice the VSI_User GPO linked to this OU.

3) Right click this object and click on edit.
4) In the new window that opens up, Browse to User Configuration->Windows Settings->Scripts (logon & logoff)
5) Double-click the Logon script option. In the dialog that shows up, click the Add button and Browse to the VSI_Logon.cmd script file located at the \\YOURDOMAIN\sysvol\YOURDOMAIN\scripts and confirm that the script file gets added in the list of scripts to run at logon.

Before I did these steps, there was no such script listed to run at logon, which was the reason I assume the script was not executed when the users logged in.
6) Save all settings and reboot the target machine.


Please Log in to join the conversation.

01 Sep 2012 02:29 #493

Thanks for the feedback and the workaround. The logon script is set on the user object by default. But if you are happy with the workaround than that works for me.

Please Log in to join the conversation.

Start Delivering the Best End User Experience Today

Request a Demo

Login VSI, Inc.

3945 Freedom Circle
Suite 670
Santa Clara, CA 95054

Phone: +1 408 899 7418

Login VSI B.V.

De Entree 85
1101 BH Amsterdam
The Netherlands

Phone: +31 20 705 1200