login vsi company logo login vsi company logo 250x40
header-05.jpg

normal 7zip Executable not found during test start up

  • Robinson
  • Robinson's Avatar Topic Author
09 Sep 2014 04:38 #2142 by Robinson
Robinson created the topic: 7zip Executable not found during test start up
Hi

I'm having a hard time of it getting a test to run. I have isolated my target servers away from other GPO and have managed to get the login script to kick into life.

The problem is that it complains about 7zip exe not found. I have installed both 32 and 64 bit versions (i.e. it exists in both program file directories) and I can't figure out for the life of me what is wrong.

The tail of the error log is as follows

2014-09-09 16:12:34,Readsettings:Verify_runtime_files=1
2014-09-09 16:12:34,Veritfication on run time files initiating.
2014-09-09 16:12:34,Checking 7Zip executable...
2014-09-09 16:12:34,Starting screenshot routine
2014-09-09 16:12:34,Screenshot, move mouse and wait: 5 seconds
<eof>

Any thoughts? thanks.

Please Log in to join the conversation.

More
09 Sep 2014 09:20 #2143 by t.willemsen
t.willemsen replied the topic: 7zip Executable not found during test start up
Hello Robinson,

It looks to me that there might be a virusscanner or any other file controller application might be interfering during the logon script. If there is a Virus scanner please either turn it off or exclude the following locations:
- \\VSIShare\ (your own UNC path)
- %tmp%\VSI folder of the local computer

Can you also check after the logon has taken place if there is a folder named "VSI" and if there are files in the VSI\RunTime\ folder?

Let us know!

Please Log in to join the conversation.

  • Robinson
  • Robinson's Avatar Topic Author
09 Sep 2014 20:59 - 09 Sep 2014 22:04 #2144 by Robinson
Robinson replied the topic: 7zip Executable not found during test start up
Alas, there is no AV installed in this particular image.

If I run the target script manually, it does copy files to %temp% which in my case was c:\users\<username>\appdata\local\temp\1\

When I get the error, the HDX sessions promptly logs out as I guess the test thinks it's finished.

I don't actually see anywhere in the documentation* saying that 7zip is required - no debate that it is. Where is it looking exactly? I have manually installed it in both 64 and 32 bit locations and it still doesn't know where it is.

* I'm a shocker for missing obvious things when reading documentation :)

Please Log in to join the conversation.

More
09 Sep 2014 21:33 #2145 by d.geerlings
d.geerlings replied the topic: 7zip Executable not found during test start up
Hello,

Can you try and enable the " Do not use temp folders per session " setting?

What sometimes happens is that during the execution of the logon script %temp% points to c:\users\<username>\appdata\local\temp. After the logon script is finished %temp% is set to /1, probably after Windows Explorer loads. Since VSI uses %temp%\vsi\ to copy the files to. When the VSI engine starts it is unable to find 7zip because it is looking at c:\users\<username>\appdata\local\temp\1 while the files are located in c:\users\<username>\appdata\local\temp instead.

Please Log in to join the conversation.

  • Robinson
  • Robinson's Avatar Topic Author
09 Sep 2014 22:16 #2146 by Robinson
Robinson replied the topic: 7zip Executable not found during test start up
you beauty!

That did the trick. In my case I loaded up terminal services and manually unticked use temporary folders per session.

thank you SO much!

Please Log in to join the conversation.

  • williamholdin
  • williamholdin's Avatar
15 Oct 2015 06:33 #2641 by williamholdin
williamholdin replied the topic: 7zip Executable not found during test start up
try this..... 7-Zip 9.20
William

Please Log in to join the conversation.

  • alexs
  • alexs's Avatar
19 Nov 2015 16:50 #2675 by alexs
alexs replied the topic: 7zip Executable not found during test start up
If the "Do not use temp folders per session" setting still does not help, ensure your Engine Startup is set to "Chained." Also a simple reboot of the LoginVSI Share always helps me :)

Please Log in to join the conversation.

What our customers are saying

Eddy Zeehuisen - Gemeente Utrecht

“We didn’t want any surprises within our operating IT environment. Login VSI has brought up several performance improvements in the infrastructure. These were addressed together with the implementer and the various vendors.”

Eddy Zeehuisen, Program Manager U-Cloud at Gemeente Utrecht (Municipality of Utrecht, The Netherlands)


Shaun Donaldson - Bitdefender

"As a software vendor, the reason that we became a Login VSI customer is that we wanted to see how we compared to our competitors. After talking to VMware and Citrix about how they test their products, it became clear to me that we needed to follow our strategic partners and be able to show how our product compares favorably to our competitors. We just completed a round of tests using Login VSI and you will see white papers showing performance data."

Shaun Donaldson, Alliances Director at Bitdefender


Dan O'Farrell - Dell

"The primary goal of our VDI appliances is to simplify and to take the guesswork out of VDI, and the Login VSI tests help us to do that from a performance expectation capability. When we offer one of our appliances to our customers, we deliver benchmarks that are validated using multiple Login VSI workloads. When compared to a customer’s workload, these Login VSI-enabled benchmarks allow precise sizing estimations to be created."

Dan O'Farrell, Director, Product Marketing, Cloud & Client at Dell

Login VSI, Inc.

300 Tradecenter

Suite 3460
Woburn, MA 01801

Phone: +1 844 828 3693

Login VSI B.V.

De Entree 85
1101 BH Amsterdam
The Netherlands

Phone: +31 20 705 1200