login vsi company logo login vsi company logo 250x40
header-01.jpg

Workload error on Win10 "This app can't be activated when UAC is disabled"

  • ps.shyam
  • ps.shyam's Avatar Topic Author
27 Aug 2015 19:30 #2606

Login VSI Version: 4.1.4
Test system: Citrix XenDesktop (Pooled Random desktops).
Operating system version target: Windows 10 Enterprise RTM
Operating system version launcher(s): Windows 8.1 Update 1

Hello. I seem to be running into a workload issue on Windows 10, leading to a large number of stuck sessions (please refer to the screen captures). I tried this with PDFPrinting=1 and PDFPrinting=0, but that did not make a difference.

Attachments:

Please Log in to join the conversation.

  • ElvinA
  • ElvinA's Avatar
10 Oct 2015 22:25 #2639

Windows 10 - PDF files opening with Microsoft Edge browser and if UAC is disabled, the following error message pops up "This app can't be activated when UAC is disabled"

In Windows 10, Microsoft has made Edge browser the default application for PDF files. The problem and solution are detailed in this blog post:
appsensebigot.blogspot.co.uk/2015/07/dep...-user-file-type.html .

A summary of the steps needing to be performed follows:

Step 1 - Create the XML file to overide the default setting (follow these steps or download the attached version)Edit section
1.Export your current default app associations from an administrative command prompt run: dism /Online /Export-DefautAppAssociations:c:\temp\assoc.xml
2.Edit the XML file and reduce the list down to just the file type associations you want to change.
My XML file had the following text.


<?xml version="1.0" encoding="UTF-8"?>
-<DefaultAssociations>
<Association ApplicationName="Adobe Reader" ProgId="AcroExch.Document.11" Identifier=".pdf"/>
</DefaultAssociations>
3.Save the XML file to a location on your target machine i.e. c:\assoc\ The file needs to be stored locally, it can't be loaded from a network share.


Step 2 - Create the user PolicyEdit section
1.Create a new GPO, User Configuration -> Preferences -> Windows Settings -> Registry
2.Add a new Registry Value: •Action: Replace
•Hive: HKEY_LOCAL_MACHINE
•Key Path: Software\Policies\Microsoft\Windows\System
•Value Name: DefaultAssociationsConfiguration
•Value Type: REG_SZ
•Value Data: c:\assoc\pdf-assoc.xml (or wherever your file is and whatever it's called)
•On the Common Tab, ensure "Run in logged-on user's security context" is NOT selected



Step 3 - Apply the PolicyEdit section
Using Group Policy Management Console
1.Create a link to an existing GPO for the User Configuration Policy to set PDF file type association to the LoginVSI\Users\Target OU

I had to run a profile create run 1st and noticed that the PDF error did come up and some sessions hung during the profile create run. Once I kicked off a regular run the PDF files were being opened by the Adobe Reader application and the test runs ran successfully on all the sessions launched.

Please Log in to join the conversation.

More
12 Oct 2015 07:02 #2640

Hello ps.shyam,

This is caused by Microsoft Edge being the default app for .PDF files in Windows 10.
See the reply from ElvinA, that's what we are recommending as well.

Please Log in to join the conversation.

Start Delivering the Best End User Experience Today

Request a Demo

Login VSI, Inc.

3945 Freedom Circle
Suite 670
Santa Clara, CA 95054

Phone: +1 408 899 7418

Login VSI B.V.

De Entree 85
1101 BH Amsterdam
The Netherlands

Phone: +31 20 705 1200