login vsi company logo login vsi company logo 250x40
header-03.jpg

Test is stop at Open file dialog of Notepad

  • k-mineta
  • k-mineta's Avatar Topic Author
18 Jun 2013 02:49 #1163 by k-mineta
HI,
When I test Medium and Light workload, test is stop at open file dialog of LoginVSI notepad.
Is there any configuration to avoid this?

Open file dialog (attached screen shot) seems to point "Library>Documents" and File name "penFileDialog1".


Login VSI Version: 4.0.2
Test system: Citrix XenDesktop
Operating system version target: Windows 7 Sp1 64bit
Operating system version launcher(s): Windows 7
Office version target: Office 2010
Language: Japanese
Attachments:

Please Log in to join the conversation.

  • je151
  • je151's Avatar
27 Jun 2013 07:22 #1227 by je151
Hello
I have the same problem but after a while a console opens and is compressing a file (see attached file). This happens about three times (takes between 10 and 20 minutes) and after that the openFileDialog is closed and the program resumes simulating the workload. In my environment this happens every time when a program is opened (excel, freemind, power point, …).
Was something not installed (maybe in the target setup) or must there be something configured by hand?

@VSI moderator: I do not know if this is a bug, but I am using office 2010 and the “Microsoft office print sequence” should be {altdown}fpp{altup} (default by VSI management console) and it does not work. I tried {ctrldown}p{ctrlup}{enter} and this works. Note: The “{enter}” was added by me to activate the print sequence.

Login VSI Version: 4.0.2
Connection over RDP
Target OS: Windows 7 Sp1 64bit
Language: german
Attachments:

Please Log in to join the conversation.

More
27 Jun 2013 09:28 #1230 by o.bouhaj
Hi K,

Do you still face this issue?

Are you sure that the latest version/patch of VSI is installed? We updated the Japanese Language file.
Looks like the file 'Open' dialog is not recognized (since it’s in Japanese) we need to make sure that the language file is correct. You can locate the file in; \\HOST\VSISHARE\_VSI_Configuration\_CurrentTest\LanguageSettings.csv

can you paste me what’s in that file please? also make sure that the correct language profile is selected in the VSI management console; Management Console > Workload > Settings\Workload language

Attached are two screenshots. 1 = VSI MMC, 2 = LanguageSettings.csv

Thanks,

Omar
Attachments:

Please Log in to join the conversation.

More
27 Jun 2013 09:56 - 27 Jun 2013 10:00 #1231 by o.bouhaj

je151 wrote: Hello
I have the same problem but after a while a console opens and is compressing a file (see attached file). This happens about three times (takes between 10 and 20 minutes) and after that the openFileDialog is closed and the program resumes simulating the workload. In my environment this happens every time when a program is opened (excel, freemind, power point, …).
Was something not installed (maybe in the target setup) or must there be something configured by hand?

@VSI moderator: I do not know if this is a bug, but I am using office 2010 and the “Microsoft office print sequence” should be {altdown}fpp{altup} (default by VSI management console) and it does not work. I tried {ctrldown}p{ctrlup}{enter} and this works. Note: The “{enter}” was added by me to activate the print sequence.


After a while(?) Looks like it takes more time in your environment. But it seems to workload continues. So it’s not an issue. The console compressing is part of the Workload. What happens every time when a program is opened? The workload has no influences on the Target setup and vice versa.

Interesting; Office 2010 (Word) print sequence is 100% alt+f+p+p (alt-fpp) (English) I know that the German Office has a different print sequence; alt+d+u+u+u (alt-duuu) - {altdown}duuu{altup}. Please note: that this is based on Office 2007, but from experience Office 2010 is also working with it.

I can try, when I have time, to reproduce this issue.

Thanks,

Omar

Please Log in to join the conversation.

  • je151
  • je151's Avatar
27 Jun 2013 10:19 #1232 by je151
Hi Omar
Thank you for your quick response and your solution for my print bug, now it works.

Please Log in to join the conversation.

  • k-mineta
  • k-mineta's Avatar Topic Author
28 Jun 2013 10:15 #1240 by k-mineta
Yes, but I found "VSI_Timer()" instruction cause this behavior. So I'd removed all "VSI_Timer()" from workload for the test.

We are using Login VSI 4.0.2. And LanguageSettings.csv setting is below. Outlook setting is changed from default since outlook mailbox setting is not properly set for Japanese. This setting come from another thread.
www.loginvsi.com/forum/support-v4/707-japanese-support-for-4-0

ID,EN,NL,DE,JP
Outlook,Inbox,Postvak IN,DE,Outlook
OutlookMessage,Message (HTML),Bericht (HTML),DE,メッセージ
Print,Print,Afdrukken,DE,印刷
Open,Open,Openen,DE,開く
Notepad,Notepad,Notepad,Notepad,Notepad
ExcelGoto,Go To,Ga naar,DE,ジャンプ

Please Log in to join the conversation.

More
04 Jul 2013 12:59 #1251 by o.bouhaj
Hi K-mineta,

Interesting; We have seen JP environments work with the Official Workloads. It’s not specific that VSI_Timer causes the Workload not to continue. I suggest not removing VSI_Timers from a workload, since they are highly required for the results and load generation.

Is it possible to overview the components in your environment and configure it correct?

Thanks,

Omar

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
17 Jul 2013 18:54 - 17 Jul 2013 18:54 #1291 by jingsu
I am experiencing this same bug. See attachment:

We are running vanilla english Windows 7 (64-bit) with an ActiveDirectory setup, shares go to a UNC share path.

The VM is responsive and the host is underloaded (this is just a trial for us to get the setup working).

We are using standard english Office 2003, but it appears to be stuck in notepad.

We are using VSI 4.0.2.
Attachments:

Please Log in to join the conversation.

More
17 Jul 2013 18:59 #1292 by d.geerlings
Jingsu,

This is a known issue regarding Office 2003. I have a hotfix available that solves this issue. Are you okay with using a hotfix. A hotfix has had limited testing.

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
17 Jul 2013 19:01 #1293 by jingsu
sure we can give the hotfix a try.

Is this a fix that has to be baked into the VM image, or is this a patch that goes into the VSISHARE folder?

Please Log in to join the conversation.

More
17 Jul 2013 19:05 #1294 by d.geerlings
I will contact you by email. For anyone else experiencing this specific issue, getting stuck on the Open file dialog of notepad while using office 2003, let me know and i will send you the hotfix as well.

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
19 Jul 2013 20:07 #1307 by jingsu
The hotfix helped get us past the stuck dialog but now our tests are stuck at a different dialog.

Screenshot is attached.

The VSI benchmark quits thinking Outlook window did not appear. But the Compose Message window is clearly open and in the foreground.
Attachments:

Please Log in to join the conversation.

More
23 Jul 2013 10:37 #1309 by o.bouhaj
Jingsu,

Attached a screenshot with the correct 'message window title' highlighted.
Please adjust the LanguageSettings file located at; \\<host>\<vsishare>\_vsi_configuration\_currenttest\LanguageSettings.csv

Let me know if this works for you.

Thanks,

Omar
Attachments:

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
23 Jul 2013 15:15 #1311 by jingsu
Hi,

Your patch fixed the outlook problem, but I'm getting a subsequent Excel problem.
Attachments:

Please Log in to join the conversation.

More
23 Jul 2013 16:15 #1312 by o.bouhaj
Hi Jingsu,

I suggest updating the bits to the latest version (bugs solved in the latest patch (0.3)) and retry
www.loginvsi.com/download

Ps, the latest version includes all the fixes discussed.

Keep me posted, thanks.

Omar

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
24 Jul 2013 18:54 #1321 by jingsu
I downloaded the latest (4.0.3) and updated the proper bits.
It fixed most but not all of the running sessions. I did a profile create of 50 and 7 are stuck on a VSI error.
screenshot attached.
Attachments:

Please Log in to join the conversation.

More
25 Jul 2013 08:47 #1322 by o.bouhaj
Hi Jingsu,

interesting. profilecreate has the proper setup/actions for excel though i just verified it.
about the error you have: its random and not on all sessions, can indicate that maybe something else is wrong on other components.
however, i will try to reproduce it and give you feedback.

suggestion: you can safely ignore the excel error and try running a normal medium test for 50 sessions and consider that 1st run as 'profile create' and get rid of those results.

Thanks,

Omar

Please Log in to join the conversation.

More
25 Jul 2013 10:28 #1326 by o.bouhaj
PS, since you are using office 2003 please make sure that the following - Microsoft Office Compatibility Pack for Word, Excel, and PowerPoint File Formats - is installed for all Targets

www.microsoft.com/en-us/download/details.aspx?id=3

Thanks,

Omar

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
25 Jul 2013 14:41 #1327 by jingsu
The compat package is infact installed.

However, I noticed this dialog which may be a clue to the VSI error.

It appears the file gets opened in read only mode, and so certain subsequent operations might not behave as expected. I'm not sure why this happens. I'm using active directory with roaming profiles.
Attachments:

Please Log in to join the conversation.

More
26 Jul 2013 14:48 #1331 by o.bouhaj
Jing,

Can you check the content-lib and see whether 'read-only' is enable on one of the excel files:

Go to the folders involved, right click, properties, untick the read only.

PS, xl00000000.xls is not of ourselves either .. did it rename itself?

Thanks,

Omar

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
04 Sep 2013 14:47 - 04 Sep 2013 15:02 #1388 by jingsu
I've gotten past the excel file weirdness. I've upgraded to the latest VSI 4.0.4.2951, and I'm seeing the notepad stuck on Open dialog once again.

attached is screenshot of the VSI debug log on the host with vsi user login showing the notepad error.
Attachments:

Please Log in to join the conversation.

  • ThinIsFat
  • ThinIsFat's Avatar
05 Sep 2013 06:54 - 05 Sep 2013 09:02 #1390 by ThinIsFat
Hi jingsu,

I am using 4.0.3 release on French environment, playing with medium workload, and I faced the same issue. However, the OpenFileDialog1 (the language setting file is correctly set for French) closes after a while and the workload resumes.

However, I am still facing an issue where the LoginVSI texteditor display a print dialog box as "Impression" and Winword displays it as "Imprimer". This is caused because the vsinotepad.exe uses a different Win32 API than MSOffice or even notepad.exe to call the Print dialog box
Is there a way to capture/know the sequence ID ? in the language settings file, each line starts with an ID maybe this way I would get a workaround and simulate properly

Another option would be a possibility to remove the Print action from the LoginVSI texteditor, only leaving the PDF_Print actions...

Thanks
Frederic

Please Log in to join the conversation.

  • ThinIsFat
  • ThinIsFat's Avatar
05 Sep 2013 09:01 #1391 by ThinIsFat
Hi,

I noticed the same issue (XenApp 6.5 running on an English OS with French MUI and Office 2003 FR). the C:\LoginVSI\_VSI_Content subfolders regain some read-only properties randomly. the filename is indeed shown as "xl00000000.xls", certainly because of some readonly issue.

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
05 Sep 2013 14:07 #1392 by jingsu
Hi Frederic,

I noticed that some of my VMs (not all) continue after a VERY long halt on the notepad open dialog. However, if you check the debug log, it's considered a VSI error and it results in extremely wrong VSIMax timing calculations.

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
05 Sep 2013 14:16 #1393 by jingsu
Hi Frederic,

I finally figured out this problem. You need to be on SP3 for office 2003. Anything less and the Compat Pack behaves differently.
support.microsoft.com/kb/923618

LoginVSI should add this to their PDF documentation.

Please Log in to join the conversation.

  • ThinIsFat
  • ThinIsFat's Avatar
05 Sep 2013 14:19 #1394 by ThinIsFat
excellent feedback, I'm going to test it right away, as I am using plain Office 2003

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
10 Sep 2013 15:27 #1401 by jingsu
Is there any additional help for this from LoginVSI? This is killing my ability to run a benchmark and have meaningful results. I know I'm on an express license but it's hard for me to go to my boss and ask for money when I can't answer "yes" to "does the benchmark work?"

I'm having the same issue as before; VSI appears to hang on Notepad's Open dialog box. I'm using a custom Language CSV in the management console's language settings, as per previous recommendations in the forum. The Open entry in the CSV matches what appears in the debug dump of VSI's view of Windows list ("Open").

Please Log in to join the conversation.

  • jingsu
  • jingsu's Avatar
12 Sep 2013 15:49 #1403 by jingsu
I'm attaching another screenshot for this notepad problem.

It was previously obscured by the VSI banner, but VSI appears to have filled the filename field with 'openFileDialog1'.

I suspect there is a bug somewhere which is causing VSI (or AutoIT) to type into the dialog box instead of triggering some kind of action.
Attachments:

Please Log in to join the conversation.

Start Delivering the Best End User Experience Today

Request a Demo

Login VSI, Inc.

3945 Freedom Circle
Suite 670
Santa Clara, CA 95054

Phone: +1 408 899 7418

300 Tradecenter
Suite 3460
Woburn, MA 01801

Phone: +1 408 899 7418

Login VSI B.V.

De Entree 85
1101 BH Amsterdam
The Netherlands

Phone: +31 20 705 1200