login vsi company logo login vsi company logo 250x40
header-01.jpg

SFConnect fails with Error gathering resources / token for resources"

  • squevill
  • squevill's Avatar Topic Author
14 Nov 2013 19:35 #1487 by squevill
I am trying to use the SFConnect utility to launch some virtual desktop sessions. We use XenDesktop 7.0. the StoreFront server it setup to use http (not https) at the moment.

This is the output:
[2013-11-14 14:31:09] Connecting to URL cscxdsbst001.thebeast.local/Citrix/thebeast
[2013-11-14 14:31:09] Got "unauthorized" response, trying to authenticate
[2013-11-14 14:31:09] Getting token for http://cscxdsbst001/Citrix/TheBeast/resources/v2
[2013-11-14 14:31:09] Getting token for http://cscxdsbst001/Citrix/Authentication/auth/v1/token
[2013-11-14 14:31:09] Using protocol ExplicitForms
[2013-11-14 14:31:09] Authenticating user credentials
Error gathering resources
Error getting authentication token for resources

Note that this works fine with our other XenDesktop 7.1 environment (which is using https). Is SFConnect suppose to work with plain http to communication to the StoreFront?

Please Log in to join the conversation.

More
15 Nov 2013 00:03 #1488 by d.geerlings
Can you post the command line you are using?

Please Log in to join the conversation.

More
15 Nov 2013 00:05 #1489 by d.geerlings
Actually, can you replace thebeast in your url with the case sensitive TheBeast?

Please Log in to join the conversation.

  • squevill
  • squevill's Avatar Topic Author
15 Nov 2013 12:59 - 22 Nov 2013 12:44 #1490 by squevill
This is the command lilne:
Z:\LoginVSI407\SFConnect.exe /url "{url}" /user "{user}" /password "{password}" /resource "{desktop}" /display absolute /displayabsolute 800x600

This is the .session entry that I was using (does not work):
Win7 Dev 64,thebeast.local,thebeast.local\x-squevill,xxxxxx, cscxdsbst001.thebeast.local/Citrix/thebeast


This is the .session entry that works:
Win7 Dev 64,thebeast.local,thebeast.local\x-squevill,xxxxxx, cscxdsbst001.thebeast.local/Citrix/TheBeast

I have also enabled https on my StoreFront and it works with https as well.

* I have change the password to protect the innocent.

Thanks for your suggestion!!!

Now, If I could only get the /display options to work, I'd be all set.

Please Log in to join the conversation.

Start Delivering the Best End User Experience Today

Request a Demo

Login VSI, Inc.

3945 Freedom Circle
Suite 670
Santa Clara, CA 95054

Phone: +1 408 899 7418

300 Tradecenter
Suite 3460
Woburn, MA 01801

Phone: +1 408 899 7418

Login VSI B.V.

De Entree 85
1101 BH Amsterdam
The Netherlands

Phone: +31 20 705 1200