login vsi company logo login vsi company logo 250x40
header-02.jpg

Adobe Reader XI not set as Default PDF Viewer in Server 2012 R2 RDS

  • Andrew_Dell
  • Andrew_Dell's Avatar Topic Author
25 Feb 2014 10:45 #1642 by Andrew_Dell
Hi I have a 2012R2 remote desktop session host environment with four session hosts. During login VSI testing I get a pop-up from Adobe Reader saying Adobe Reader is not the default PDF viewer, would I like to set it a my default viewer ? Eventually the session times out. I checked the Default Programs associations for Adobe Reader inside the test session and .pdf was unticked (see attached screen shot).
However Adobe Reader is set at the default pdf reader on all of the session hosts if I log on to any of the session hosts as a local admin.
The setting seems to get disabled when the LoginVSI test run begins. As this is server 2012R2 Microsoft PDF Reader is not installed to cause a conflict and I have tried using a GP to force reader as the default PDF reader.

Have you seen an issue like this before in an RDS environment ? Is this possibly something to do with Adobe Reader itself and not the testing process ?

Thanks,
Andrew
Attachments:

Please Log in to join the conversation.

More
25 Feb 2014 11:52 #1643 by t.willemsen
Hello Andrew,

We are aware that Windows 8.x has this exact issue because it will automatically change the standard PDF viewer to its own app. We have never seen this problem in Windows Server 2012R2. But the fix for windows 8 (that already has been implemented) also works for Windows Server 2012R2. To specify, whenever a workload starts it will inject windows with new registry keys to disable or enable specific functions.

What i can suggest is that you uninstall Adobe from your machine and re-install it using our target setup. This way all the default settings that we have configured in the Adobe install will be configured correctly.

Please let me know how this works out.

Please Log in to join the conversation.

More
25 Feb 2014 19:06 - 25 Feb 2014 19:07 #1647 by d.geerlings
Andrew,

Did you use this method to set the file type association? Windows 8.1 (and probably 2012 R2) have a feature that lets user preference overwrite programmatic settings. The article linked above should allow you to set that using group policy settings

Please Log in to join the conversation.

  • Andrew_Dell
  • Andrew_Dell's Avatar Topic Author
26 Feb 2014 14:18 #1650 by Andrew_Dell
Thanks Tom and Dennis for your assistance on this.
I tried the install and re-install method. I installed in the session host install mode (change user /install) using the following commnd line "AdbeRdr11000_en_US.msi /qb /norestart ALLUERS=1 EULA_ACCEPT=YES SUPPRESS_APP_LAUNCH=YES" but again no luck.

Dennis I was originally trying the method you suggest below but the DC we are using Windows 2008 doesnt seem to have the "Computer configuration\administrative templates Windows Components\File Explorer\" GP setting.

At the moment I am focusing on disabling the warning inside Adobe Reader. I am looking for a resgistry key that disables the "Tell me if Adobe Reader is not my default PDF application"

If you have come across such a registry please let me know.

Thanks,
Andrew
Attachments:

Please Log in to join the conversation.

  • Andrew_Dell
  • Andrew_Dell's Avatar Topic Author
26 Feb 2014 14:22 #1651 by Andrew_Dell
Actually one extra point to note. At the start of test the PDFs are opened sucessfully by Adobe reader with no dialogue boxes. It seems to be later in the test cycle that the dialogue box pops up.

Please Log in to join the conversation.

More
26 Feb 2014 16:18 #1652 by o.bouhaj
Hi Andrew,

_At the moment I am focusing on disabling the warning inside Adobe Reader. I am looking for a resgistry key that disables the "Tell me if Adobe Reader is not my default PDF application"_

I have found the exact key value (with ProcMon).
1- You can set this via GPO
2- You can place the reg injection in the workload and then add it to the 'prepare phase'

Option1:
*HKCU\Software\Adobe\Acrobat Reader\11.0\AVAlert\cCheckbox\iAppDoNotTakePDFOwnershipAtLaunch*
Needs to be set as *REG_DWORD* value is: *1*

Option2:
VSI_RegWrite("Workload", "HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\11.0\AVAlert\cCheckbox", "iAppDoNotTakePDFOwnershipAtLaunch ", "REG_DWORD", "1")

Keep us posted. Thanks,

Please Log in to join the conversation.

  • Andrew_Dell
  • Andrew_Dell's Avatar Topic Author
26 Feb 2014 18:32 #1654 by Andrew_Dell
Hi All
We eventually got this working using a variation on setting the default pdf reader through group policy as suggested by Dennis. Instead of setting the group policy object through our domain controller I set a local group policy individually on each of the session hosts to use a loca defaultassociations.xml on each session host.

Thanks for all your assistance.
Andrew

Please Log in to join the conversation.

Start Delivering the Best End User Experience Today

Request a Demo

Login VSI, Inc.

3945 Freedom Circle
Suite 670
Santa Clara, CA 95054

Phone: +1 408 899 7418

300 Tradecenter
Suite 3460
Woburn, MA 01801

Phone: +1 408 899 7418

Login VSI B.V.

De Entree 85
1101 BH Amsterdam
The Netherlands

Phone: +31 20 705 1200